What’s Vulnerable › Vulnerabilities
CVE-2022-1384: Authorized users are allowed to install old plugin versions from the Marketplace
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-19 · updated 2026-06-17
- Weakness: CWE-477
Description
Mattermost version 6.4.x and earlier fails to properly check the plugin version when a plugin is installed from the Marketplace, which allows an authenticated and an authorized user to install and exploit an old plugin version from the Marketplace which might have known vulnerabilities.
Affected products
- Mattermost: before 6.5.0 — fixed in 6.5.0
How to fix
Upgrade to a fixed version: Mattermost 6.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-1384 or the next vulnerability affects your stack