What’s Vulnerable › Vulnerabilities
CVE-2022-1393: WP Subtitle < 3.4.1 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Subtitle WordPress plugin before 3.4.1 adds a subtitle field and provides a shortcode to display it via [wp_subtitle]. The subtitle is stored as a custom post meta with the key: "wps_subtitle", which is sanitized upon post save/update, however is not sanitized when updating it directly from the post meta update button (via AJAX) - and this makes the XSS exploitable by authenticated users with a role as low as contributor.
Affected products
- WP Subtitle: before 3.4.1 — fixed in 3.4.1
How to fix
Upgrade to a fixed version: WP Subtitle 3.4.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3491b889-94dd-4507-9fed-58f48d8275cf
- https://wpscan.com/vulnerability/3491b889-94dd-4507-9fed-58f48d8275cf
Get alerted when CVE-2022-1393 or the next vulnerability affects your stack