What’s Vulnerable › Vulnerabilities
CVE-2022-1394: Photo Gallery < 1.6.4 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The Photo Gallery by 10Web WordPress plugin before 1.6.4 does not properly validate and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks when unfiltered_html is disallowed
Affected products
- 10web Photo Gallery by 10Web – Mobile-Friendly Image Gallery: before 1.6.4 — fixed in 1.6.4
How to fix
Upgrade to a fixed version: 10web Photo Gallery by 10Web – Mobile-Friendly Image Gallery 1.6.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f7a0df37-3204-4926-84ec-2204a2f22de3
- https://wpscan.com/vulnerability/f7a0df37-3204-4926-84ec-2204a2f22de3
Get alerted when CVE-2022-1394 or the next vulnerability affects your stack