What’s Vulnerable › Vulnerabilities
CVE-2022-1397: API Privilege Escalation in alextselegidis/easyappointments
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-10 · updated 2026-06-17
- Weakness: CWE-269
Description
API Privilege Escalation in GitHub repository alextselegidis/easyappointments prior to 1.5.0. Full system takeover.
Affected products
- alextselegidis/easyappointments: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: alextselegidis/easyappointments 1.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/alextselegidis/easyappointments/commit/63dbb51decfcc1631c398ecd6d30e3a337845526
- https://huntr.dev/bounties/5f69e094-ab8c-47a3-b01d-8c12a3b14c61
- https://github.com/alextselegidis/easyappointments/commit/63dbb51decfcc1631c398ecd6d30e3a337845526
- https://huntr.dev/bounties/5f69e094-ab8c-47a3-b01d-8c12a3b14c61
Get alerted when CVE-2022-1397 or the next vulnerability affects your stack