What’s Vulnerable › Vulnerabilities
CVE-2022-1408: VikBooking Hotel Booking Engine & PMS < 1.5.8 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The VikBooking Hotel Booking Engine & PMS WordPress plugin before 1.5.8 does not escape various settings before outputting them in attributes, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
Affected products
- VikBooking Hotel Booking Engine & PMS: before 1.5.8 — fixed in 1.5.8
How to fix
Upgrade to a fixed version: VikBooking Hotel Booking Engine & PMS 1.5.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/48dccf4c-07e0-4877-867d-f8f43aeb5705
- https://wpscan.com/vulnerability/48dccf4c-07e0-4877-867d-f8f43aeb5705
Get alerted when CVE-2022-1408 or the next vulnerability affects your stack