What’s Vulnerable › Vulnerabilities
CVE-2022-1409: VikBooking Hotel Booking Engine & PMS < 1.5.8 - Admin+ PHP File Upload
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-16 · updated 2026-06-17
- Weakness: CWE-434
Description
The VikBooking Hotel Booking Engine & PMS WordPress plugin before 1.5.8 does not properly validate images, allowing high privilege users such as administrators to upload PHP files disguised as images and containing malicious PHP code
Affected products
- VikBooking Hotel Booking Engine & PMS: before 1.5.8 — fixed in 1.5.8
How to fix
Upgrade to a fixed version: VikBooking Hotel Booking Engine & PMS 1.5.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1330f8f7-4a59-4e9d-acae-21656a4101fe
- https://wpscan.com/vulnerability/1330f8f7-4a59-4e9d-acae-21656a4101fe
Get alerted when CVE-2022-1409 or the next vulnerability affects your stack