What’s Vulnerable › Vulnerabilities
CVE-2022-1419
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-02 · updated 2026-06-17
- Weakness: CWE-416
Description
The root cause of this vulnerability is that the ioctl$DRM_IOCTL_MODE_DESTROY_DUMB can decrease refcount of *drm_vgem_gem_object *(created in *vgem_gem_dumb_create*) concurrently, and *vgem_gem_dumb_create *will access the freed drm_vgem_gem_object.
Affected products
- Debian Linux: 10.0
- Linux kernel: before 5.6; 5.6, 5.6-rc1 — fixed in 5.6
How to fix
Upgrade to a fixed version: Linux kernel 5.6. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2077560
- https://www.debian.org/security/2022/dsa-5173
- https://bugzilla.redhat.com/show_bug.cgi?id=2077560
- https://www.debian.org/security/2022/dsa-5173
Get alerted when CVE-2022-1419 or the next vulnerability affects your stack