What’s Vulnerable › Vulnerabilities
CVE-2022-1421: Discy < 5.2 - Settings Update via CSRF
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-08 · updated 2026-06-17
- Weakness: CWE-352
Description
The Discy WordPress theme before 5.2 lacks CSRF checks in some AJAX actions, allowing an attacker to make a logged in admin change arbitrary 's settings including payment methods via a CSRF attack
Affected products
- Discy: before 5.2 — fixed in 5.2
How to fix
Upgrade to a fixed version: Discy 5.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a7a24e8e-9056-4967-bcad-b96cc0c5b249
- https://wpscan.com/vulnerability/a7a24e8e-9056-4967-bcad-b96cc0c5b249
Get alerted when CVE-2022-1421 or the next vulnerability affects your stack