What’s Vulnerable › Vulnerabilities
CVE-2022-1430: Cross-site Scripting (XSS) - DOM in octoprint/octoprint
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - DOM in GitHub repository octoprint/octoprint prior to 1.8.0.
Affected products
- OctoPrint: before 1.8.0 — fixed in 1.8.0
How to fix
Upgrade to a fixed version: OctoPrint 1.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/octoprint/octoprint/commit/8087528e4a7ddd15c7d95ff662deb5ef7de90045
- https://huntr.dev/bounties/0cd30d71-1e32-4a0b-b4c3-faaa1907b541
- https://github.com/octoprint/octoprint/commit/8087528e4a7ddd15c7d95ff662deb5ef7de90045
- https://huntr.dev/bounties/0cd30d71-1e32-4a0b-b4c3-faaa1907b541
Get alerted when CVE-2022-1430 or the next vulnerability affects your stack