What’s Vulnerable › Vulnerabilities

CVE-2022-1431

Description

An issue has been discovered in GitLab affecting all versions starting from 12.10 before 14.8.6, all versions starting from 14.9 before 14.9.4, all versions starting from 14.10 before 14.10.1. GitLab was not correctly handling malicious requests to the PyPi API endpoint allowing the attacker to cause uncontrolled resource consumption.

Affected products

How to fix

Upgrade to a fixed version: GitLab 14.8.6, 14.9.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-1431 or the next vulnerability affects your stack