What’s Vulnerable › Vulnerabilities
CVE-2022-1432: Cross-site Scripting (XSS) - Generic in octoprint/octoprint
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Generic in GitHub repository octoprint/octoprint prior to 1.8.0.
Affected products
- OctoPrint: before 1.8.0 — fixed in 1.8.0
How to fix
Upgrade to a fixed version: OctoPrint 1.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/octoprint/octoprint/commit/6d259d7e6f5b0de9a1c762831537a386e53978d3
- https://huntr.dev/bounties/cb545c63-a3c1-4d57-8f06-e4593ab389bf
- https://github.com/octoprint/octoprint/commit/6d259d7e6f5b0de9a1c762831537a386e53978d3
- https://huntr.dev/bounties/cb545c63-a3c1-4d57-8f06-e4593ab389bf
Get alerted when CVE-2022-1432 or the next vulnerability affects your stack