What’s Vulnerable › Vulnerabilities
CVE-2022-1434: Incorrect MAC key used in the RC4-MD5 ciphersuite
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-03 · updated 2026-10-14
- Weakness: CWE-327
Description
The OpenSSL 3.0 implementation of the RC4-MD5 ciphersuite incorrectly uses the AAD data as the MAC key. This makes the MAC key trivially predictable. An attacker could exploit this issue by performing a man-in-the-middle attack to modify data being sent from one endpoint to an OpenSSL 3.0 recipient such that the modified data would still pass the MAC integrity check. Note that data sent from an OpenSSL 3.0 endpoint to a non-OpenSSL 3.0 endpoint will always be rejected by the recipient and the connection will fail at that point. Many application protocols require data to be sent from the client to the server first. Therefore, in such a case, only an OpenSSL 3.0 server would be impacted when talking to a non-OpenSSL 3.0 client. If both endpoints are OpenSSL 3.0 then the attacker could modify data being sent in both directions. In this case both clients and servers could be affected, regardless of the application protocol. Note that in the absence of an attacker this bug means that an OpenSSL 3.0 endpoint communicating with a non-OpenSSL 3.0 endpoint will fail to complete the handshake when using this ciphersuite. The confidentiality of data is not impacted by this issue, i.e. an attacker cannot decrypt data that has been encrypted using this ciphersuite - they can only modify it. In order for this attack to work both endpoints must legitimately negotiate the RC4-MD5 ciphersuite. This ciphersuite is not compiled by default in OpenSSL 3.0, and is not available within the default provider or the default ciphersuite list. This ciphersuite will never be used if TLSv1.3 has been negotiated. In order for an OpenSSL 3.0 endpoint to use this ciphersuite the following must have occurred: 1) OpenSSL must have been compiled with the (non-default) compile time option enable-weak-ssl-ciphers 2) OpenSSL must have had the legacy provider explicitly loaded (either through application code or via configuration) 3) The ciphersuite must have been explicitly added to the ciphersuite list 4) The libssl security level must have been set to 0 (default is 1) 5) A version of SSL/TLS below TLSv1.3 must have been negotiated 6) Both endpoints must negotiate the RC4-MD5 ciphersuite in preference to any others that both endpoints have in common Fixed in OpenSSL 3.0.3 (Affected 3.0.0,3.0.1,3.0.2).
Affected products
- NetApp A250 Firmware: all versions
- NetApp A700S Firmware: all versions
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: all versions
- NetApp Aff 500F Firmware: all versions
- NetApp Aff 8300 Firmware: all versions
- NetApp Aff 8700 Firmware: all versions
- NetApp Aff A400 Firmware: all versions
- Clustered Data ONTAP: all versions
- NetApp Clustered Data Ontap Antivirus Connector: all versions
- NetApp Fabric-Attached Storage A400 Firmware: all versions
- NetApp Fas 500F Firmware: all versions
- NetApp Fas 8300 Firmware: all versions
- NetApp Fas 8700 Firmware: all versions
- NetApp H300E Firmware: all versions
- NetApp H300S Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500E Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700E Firmware: all versions
- NetApp H700S Firmware: all versions
- NetApp Santricity Smi-S Provider: all versions
- NetApp Smi-S Provider: all versions
- SnapManager for Oracle: all versions
- NetApp Solidfire, Enterprise Sds & Hci Storage Node: all versions
- NetApp Solidfire & Hci Management Node: all versions
- OpenSSL: from 3.0.0 before 3.0.3 — fixed in 3.0.3
How to fix
Upgrade to a fixed version: OpenSSL 3.0.3. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-953464.pdf
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=7d56a74a96828985db7354a55227a511615f732b
- https://security.netapp.com/advisory/ntap-20220602-0009/
- https://www.openssl.org/news/secadv/20220503.txt
- https://cert-portal.siemens.com/productcert/pdf/ssa-953464.pdf
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=7d56a74a96828985db7354a55227a511615f732b
- https://security.netapp.com/advisory/ntap-20220602-0009/
- https://www.openssl.org/news/secadv/20220503.txt
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://cert-portal.siemens.com/productcert/html/ssa-794697.html
- https://cert-portal.siemens.com/productcert/html/ssa-953464.html
Get alerted when CVE-2022-1434 or the next vulnerability affects your stack