What’s Vulnerable › Vulnerabilities
CVE-2022-1440: Command Injection vulnerability in git-interface@2.1.1 in yarkeev/git-interface
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-22 · updated 2026-06-17
- Weakness: CWE-78
Description
Command Injection vulnerability in git-interface@2.1.1 in GitHub repository yarkeev/git-interface prior to 2.1.2. If both are provided by user input, then the use of a `--upload-pack` command-line argument feature of git is also supported for `git clone`, which would then allow for any operating system command to be spawned by the attacker.
Affected products
- yarkeev/git-interface: before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: yarkeev/git-interface 2.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/yarkeev/git-interface/commit/f828aa790016fee3aa667f7b44cf94bf0aa8c60d
- https://huntr.dev/bounties/cdc25408-d3c1-4a9d-bb45-33b12a715ca1
- https://github.com/yarkeev/git-interface/commit/f828aa790016fee3aa667f7b44cf94bf0aa8c60d
- https://huntr.dev/bounties/cdc25408-d3c1-4a9d-bb45-33b12a715ca1
Get alerted when CVE-2022-1440 or the next vulnerability affects your stack