What’s Vulnerable › Vulnerabilities
CVE-2022-1442: Metform Elementor Contact Form Builder <= 2.1.3 - Sensitive Information Disclosure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-10 · updated 2026-06-17
- Weakness: CWE-862
Description
The Metform WordPress plugin is vulnerable to sensitive information disclosure due to improper access control in the ~/core/forms/action.php file which can be exploited by an unauthenticated attacker to view all API keys and secrets of integrated third-party APIs like that of PayPal, Stripe, Mailchimp, Hubspot, HelpScout, reCAPTCHA and many more, in versions up to and including 2.1.3.
Affected products
- roxnor MetForm – Contact Form, Survey, Quiz, & Custom Form Builder for Elementor: before 2.1.4 — fixed in 2.1.4
How to fix
Upgrade to a fixed version: roxnor MetForm – Contact Form, Survey, Quiz, & Custom Form Builder for Elementor 2.1.4. Check the vendor advisory for mitigations.
References
- https://gist.github.com/Xib3rR4dAr/6e6c6e5fa1f8818058c7f03de1eda6bf
- https://plugins.trac.wordpress.org/changeset/2711944/metform/trunk/core/forms/action.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/04a46249-b5b2-4082-b520-cdc4a1370bb1?source=cve
- https://gist.github.com/Xib3rR4dAr/6e6c6e5fa1f8818058c7f03de1eda6bf
- https://plugins.trac.wordpress.org/changeset/2711944/metform/trunk/core/forms/action.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/04a46249-b5b2-4082-b520-cdc4a1370bb1?source=cve
Get alerted when CVE-2022-1442 or the next vulnerability affects your stack