What’s Vulnerable › Vulnerabilities
CVE-2022-1453: RSVPMaker <= 9.2.5 - Unauthenticated SQL Injection
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-10 · updated 2026-06-17
- Weakness: CWE-89
Description
The RSVPMaker plugin for WordPress is vulnerable to unauthenticated SQL Injection due to missing SQL escaping and parameterization on user supplied data passed to a SQL query in the rsvpmaker-util.php file. This makes it possible for unauthenticated attackers to steal sensitive information from the database in versions up to and including 9.2.5.
Affected products
- David F. Carr RSVPMaker: before 9.2.6 — fixed in 9.2.6
How to fix
Upgrade to a fixed version: David F. Carr RSVPMaker 9.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/davidfcarr/rsvpmaker/commit/bfb189f49af7ab0d34499a2da772e3266f72167d
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2714389%40rsvpmaker&new=2714389%40rsvpmaker&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6031edec-4274-4e42-9e3a-ce0c94958b17?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1453
- https://github.com/davidfcarr/rsvpmaker/commit/bfb189f49af7ab0d34499a2da772e3266f72167d
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2714389%40rsvpmaker&new=2714389%40rsvpmaker&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6031edec-4274-4e42-9e3a-ce0c94958b17?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1453
Get alerted when CVE-2022-1453 or the next vulnerability affects your stack