What’s Vulnerable › Vulnerabilities
CVE-2022-1465: WPC Smart Wishlist for WooCommerce < 2.9.9 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The WPC Smart Wishlist for WooCommerce WordPress plugin before 2.9.9 does not sanitise and escape a parameter before outputting it back in an attribute via an AJAX action, leading to a Reflected Cross-Site Scripting issue.
Affected products
- WPC Smart Wishlist for WooCommerce: before 2.9.9 — fixed in 2.9.9
How to fix
Upgrade to a fixed version: WPC Smart Wishlist for WooCommerce 2.9.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6781033a-f166-4198-874f-3e142854daf7
- https://wpscan.com/vulnerability/6781033a-f166-4198-874f-3e142854daf7
Get alerted when CVE-2022-1465 or the next vulnerability affects your stack