What’s Vulnerable › Vulnerabilities
CVE-2022-1472: Better Find and Replace < 1.3.6 - Admin+ SQLi
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-20 · updated 2026-06-17
- Weakness: CWE-89
Description
The Better Find and Replace WordPress plugin before 1.3.6 does not properly sanitise, validate and escape various parameters before using them in an SQL statement, leading to an SQL Injection
Affected products
- CodeSolz Better Find and Replace: before 1.3.6 — fixed in 1.3.6
How to fix
Upgrade to a fixed version: CodeSolz Better Find and Replace 1.3.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9c608b14-dc5e-469e-b97a-84696fae804c
- https://wpscan.com/vulnerability/9c608b14-dc5e-469e-b97a-84696fae804c
Get alerted when CVE-2022-1472 or the next vulnerability affects your stack