What’s Vulnerable › Vulnerabilities
CVE-2022-1474: WP Event Manager < 3.1.28 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Event Manager WordPress plugin before 3.1.28 does not sanitise and escape its search before outputting it back in an attribute on the event dashboard, leading to a Reflected Cross-Site Scripting
Affected products
- wpeventmanager WP Event Manager – Events Calendar, Registrations, Sell Tickets with WooCommerce: before 3.1.28 — fixed in 3.1.28
How to fix
Upgrade to a fixed version: wpeventmanager WP Event Manager – Events Calendar, Registrations, Sell Tickets with WooCommerce 3.1.28. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2d821464-c502-4f71-afee-97b3dea16612
- https://wpscan.com/vulnerability/2d821464-c502-4f71-afee-97b3dea16612
Get alerted when CVE-2022-1474 or the next vulnerability affects your stack