What’s Vulnerable › Vulnerabilities
CVE-2022-1504: XSS in /demo/module/?module=HERE in microweber/microweber
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-27 · updated 2026-06-17
- Weakness: CWE-79
Description
XSS in /demo/module/?module=HERE in GitHub repository microweber/microweber prior to 1.2.15. Typical impact of XSS attacks.
Affected products
- microweber/microweber: before 1.2.15 — fixed in 1.2.15
How to fix
Upgrade to a fixed version: microweber/microweber 1.2.15. Check the vendor advisory for mitigations.
References
- https://github.com/microweber/microweber/commit/1f6a4de416a85e626dc643bb5ceb916e4802223e
- https://huntr.dev/bounties/b8e5c324-3dfe-46b4-8095-1697c6b0a6d6
- https://github.com/microweber/microweber/commit/1f6a4de416a85e626dc643bb5ceb916e4802223e
- https://huntr.dev/bounties/b8e5c324-3dfe-46b4-8095-1697c6b0a6d6
Get alerted when CVE-2022-1504 or the next vulnerability affects your stack