What’s Vulnerable › Vulnerabilities
CVE-2022-1505: RSVPMaker <= 9.2.6 - Unauthenticated SQL Injection
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-10 · updated 2026-06-17
- Weakness: CWE-89
Description
The RSVPMaker plugin for WordPress is vulnerable to unauthenticated SQL Injection due to missing SQL escaping and parameterization on user supplied data passed to a SQL query in the rsvpmaker-api-endpoints.php file. This makes it possible for unauthenticated attackers to steal sensitive information from the database in versions up to and including 9.2.6.
Affected products
- David F. Carr RSVPMaker: before 9.2.7 — fixed in 9.2.7
How to fix
Upgrade to a fixed version: David F. Carr RSVPMaker 9.2.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2715095%40rsvpmaker&new=2715095%40rsvpmaker&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6837b91d-b3ba-435a-965b-fa18d9b9b9c8?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1505
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2715095%40rsvpmaker&new=2715095%40rsvpmaker&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6837b91d-b3ba-435a-965b-fa18d9b9b9c8?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1505
Get alerted when CVE-2022-1505 or the next vulnerability affects your stack