What’s Vulnerable › Vulnerabilities
CVE-2022-1508
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-31 · updated 2026-06-17
- Weakness: CWE-125
Description
An out-of-bounds read flaw was found in the Linux kernel’s io_uring module in the way a user triggers the io_read() function with some special parameters. This flaw allows a local user to read some memory out of bounds.
Affected products
- Linux kernel: before 5.15 — fixed in 5.15
How to fix
Upgrade to a fixed version: Linux kernel 5.15. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2022-1508
- https://bugzilla.redhat.com/show_bug.cgi?id=2075533
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=89c2b3b74918200e46699338d7bcc19b1ea12110
- https://ubuntu.com/security/CVE-2022-1508
- https://access.redhat.com/security/cve/CVE-2022-1508
- https://bugzilla.redhat.com/show_bug.cgi?id=2075533
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=89c2b3b74918200e46699338d7bcc19b1ea12110
- https://ubuntu.com/security/CVE-2022-1508
Get alerted when CVE-2022-1508 or the next vulnerability affects your stack