What’s Vulnerable › Vulnerabilities
CVE-2022-1509: Command Injection Vulnerability in hestiacp/hestiacp
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-28 · updated 2026-06-17
- Weakness: CWE-77
Description
Command Injection Vulnerability in GitHub repository hestiacp/hestiacp prior to 1.5.12. An authenticated remote attacker with low privileges can execute arbitrary code under root context.
Affected products
- hestiacp Control Panel: before 1.5.12 — fixed in 1.5.12
How to fix
Upgrade to a fixed version: hestiacp Control Panel 1.5.12. Check the vendor advisory for mitigations.
References
- https://github.com/hestiacp/hestiacp/commit/d50f95cf208049dfb6ac67a8020802121745bd60
- https://huntr.dev/bounties/09e69dff-f281-4e51-8312-ed7ab7606338
- https://github.com/hestiacp/hestiacp/commit/d50f95cf208049dfb6ac67a8020802121745bd60
- https://huntr.dev/bounties/09e69dff-f281-4e51-8312-ed7ab7606338
Get alerted when CVE-2022-1509 or the next vulnerability affects your stack