What’s Vulnerable › Vulnerabilities
CVE-2022-1527: WP 2FA < 2.2.1 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP 2FA WordPress plugin before 2.2.1 does not sanitise and escape a parameter before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting
Affected products
- WP 2FA: before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: WP 2FA 2.2.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0260d5c0-52a9-44ce-b7be-aff642056d16
- https://wpscan.com/vulnerability/0260d5c0-52a9-44ce-b7be-aff642056d16
Get alerted when CVE-2022-1527 or the next vulnerability affects your stack