What’s Vulnerable › Vulnerabilities
CVE-2022-1528: VikBooking < 1.5.9 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The VikBooking Hotel Booking Engine & PMS WordPress plugin before 1.5.9 does not escape the current URL before putting it back in a JavaScript context, leading to a Reflected Cross-Site Scripting
Affected products
- Vikwp Vik Booking: before 1.5.9 — fixed in 1.5.9
How to fix
Upgrade to a fixed version: Vikwp Vik Booking 1.5.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d1e59894-382f-4151-8c4c-5608f3d8ac1f
- https://wpscan.com/vulnerability/d1e59894-382f-4151-8c4c-5608f3d8ac1f
Get alerted when CVE-2022-1528 or the next vulnerability affects your stack