What’s Vulnerable › Vulnerabilities
CVE-2022-1538: Theme-Demo-Importer < 1.1.1 - Admin+ Arbitrary File Upload
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-434
Description
Theme Demo Import WordPress plugin before 1.1.1 does not validate the imported file, allowing high-privilege users such as admin to upload arbitrary files (such as PHP) even when FILE_MODS and FILE_EDIT are disallowed.
Affected products
- Theme Demo Import: before 1.1.1 — fixed in 1.1.1
How to fix
Upgrade to a fixed version: Theme Demo Import 1.1.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b19adf7c-3983-487b-9b46-0f2922b08c1c/
- https://wpscan.com/vulnerability/b19adf7c-3983-487b-9b46-0f2922b08c1c/
Get alerted when CVE-2022-1538 or the next vulnerability affects your stack