What’s Vulnerable › Vulnerabilities
CVE-2022-1552
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-31 · updated 2026-06-17
- Weakness: CWE-459
Description
A flaw was found in PostgreSQL. There is an issue with incomplete efforts to operate safely when a privileged user is maintaining another user's objects. The Autovacuum, REINDEX, CREATE INDEX, REFRESH MATERIALIZED VIEW, CLUSTER, and pg_amcheck commands activated relevant protections too late or not at all during the process. This flaw allows an attacker with permission to create non-temporary objects in at least one schema to execute arbitrary SQL functions under a superuser identity.
Affected products
- PostgreSQL: from 10.0 before 10.21; from 11.0 before 11.16; from 12.0 before 12.11; from 13.0 before 13.7; from 14.0 before 14.3 — fixed in 10.21, 11.16, 12.11, 13.7, 14.3
How to fix
Upgrade to a fixed version: PostgreSQL 10.21, 11.16, 12.11, 13.7. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2022-1552
- https://bugzilla.redhat.com/show_bug.cgi?id=2081126
- https://security.gentoo.org/glsa/202211-04
- https://security.netapp.com/advisory/ntap-20221104-0005/
- https://www.postgresql.org/about/news/postgresql-143-137-1211-1116-and-1021-released-2449/
- https://www.postgresql.org/support/security/CVE-2022-1552/
- https://access.redhat.com/security/cve/CVE-2022-1552
- https://bugzilla.redhat.com/show_bug.cgi?id=2081126
- https://security.gentoo.org/glsa/202211-04
- https://security.netapp.com/advisory/ntap-20221104-0005/
- https://www.postgresql.org/about/news/postgresql-143-137-1211-1116-and-1021-released-2449/
- https://www.postgresql.org/support/security/CVE-2022-1552/
Get alerted when CVE-2022-1552 or the next vulnerability affects your stack