What’s Vulnerable › Vulnerabilities
CVE-2022-1555: DOM XSS in microweber ver 1.2.15 in microweber/microweber
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-04 · updated 2026-06-17
- Weakness: CWE-79
Description
DOM XSS in microweber ver 1.2.15 in GitHub repository microweber/microweber prior to 1.2.16. inject arbitrary js code, deface website, steal cookie...
Affected products
- microweber/microweber: before 1.2.16 — fixed in 1.2.16
How to fix
Upgrade to a fixed version: microweber/microweber 1.2.16. Check the vendor advisory for mitigations.
References
- https://github.com/microweber/microweber/commit/724e2d186a33c0c27273107dc4f160a09384877f
- https://huntr.dev/bounties/d9f9b5bd-16f3-4eaa-9e36-d4958b557687
- https://github.com/microweber/microweber/commit/724e2d186a33c0c27273107dc4f160a09384877f
- https://huntr.dev/bounties/d9f9b5bd-16f3-4eaa-9e36-d4958b557687
Get alerted when CVE-2022-1555 or the next vulnerability affects your stack