What’s Vulnerable › Vulnerabilities
CVE-2022-1556: StaffList < 3.1.5 - Admin+ SQLi
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 20.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-30 · updated 2026-06-17
- Weakness: CWE-89
Description
The StaffList WordPress plugin before 3.1.5 does not properly sanitise and escape a parameter before using it in a SQL statement when searching for Staff in the admin dashboard, leading to an SQL Injection
Affected products
- era404 StaffList: before 3.1.5 — fixed in 3.1.5
How to fix
Upgrade to a fixed version: era404 StaffList 3.1.5. Check the vendor advisory for mitigations.
References
- https://packetstormsecurity.com/files/166918/
- https://wpscan.com/vulnerability/04890549-6bd1-44dd-8bce-7125c01be5d4
- https://packetstormsecurity.com/files/166918/
- https://wpscan.com/vulnerability/04890549-6bd1-44dd-8bce-7125c01be5d4
Get alerted when CVE-2022-1556 or the next vulnerability affects your stack