What’s Vulnerable › Vulnerabilities
CVE-2022-1562: Enable SVG < 1.4.0 - Author+ Stored Cross Site Scripting via SVG
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The Enable SVG WordPress plugin before 1.4.0 does not sanitise uploaded SVG files, which could allow users with a role as low as Author to upload a malicious SVG containing XSS payloads
Affected products
- Enable SVG: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: Enable SVG 1.4.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8e5b1e4f-c132-42ee-b2d0-7306ab4ab615
- https://wpscan.com/vulnerability/8e5b1e4f-c132-42ee-b2d0-7306ab4ab615
Get alerted when CVE-2022-1562 or the next vulnerability affects your stack