What’s Vulnerable › Vulnerabilities
CVE-2022-1565: Import any XML or CSV File to WordPress <= 3.6.7 - Admin+ Malicious File Upload
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 15.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-18 · updated 2026-06-17
- Weakness: CWE-434
Description
The plugin WP All Import is vulnerable to arbitrary file uploads due to missing file type validation via the wp_all_import_get_gz.php file in versions up to, and including, 3.6.7. This makes it possible for authenticated attackers, with administrator level permissions and above, to upload arbitrary files on the affected sites server which may make remote code execution possible.
Affected products
- wpallimport WP All Import – Drag & Drop Import for CSV, XML, Excel & Google Sheets: before 3.6.8 — fixed in 3.6.8
How to fix
Upgrade to a fixed version: wpallimport WP All Import – Drag & Drop Import for CSV, XML, Excel & Google Sheets 3.6.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2749264/wp-all-import/trunk?contextall=1&old=2737093&old_path=%2Fwp-all-import%2Ftrunk
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5d281333-d9af-4eb7-bc5c-ea7ceeddac03?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1565
- https://plugins.trac.wordpress.org/changeset/2749264/wp-all-import/trunk?contextall=1&old=2737093&old_path=%2Fwp-all-import%2Ftrunk
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5d281333-d9af-4eb7-bc5c-ea7ceeddac03?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1565
Get alerted when CVE-2022-1565 or the next vulnerability affects your stack