What’s Vulnerable › Vulnerabilities
CVE-2022-1578: My wpdb < 2.5 - Arbitrary SQL Query via CSRF
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-21 · updated 2026-06-17
Description
The My wpdb WordPress plugin before 2.5 is missing CSRF check when running SQL queries, which could allow attacker to make a logged in admin run arbitrary SQL query via a CSRF attack
Affected products
- My wpdb: before 2.5 — fixed in 2.5
How to fix
Upgrade to a fixed version: My wpdb 2.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c280da92-4ac2-43ea-93a2-6c583b79b98b
- https://wpscan.com/vulnerability/c280da92-4ac2-43ea-93a2-6c583b79b98b
Get alerted when CVE-2022-1578 or the next vulnerability affects your stack