What’s Vulnerable › Vulnerabilities
CVE-2022-1581: WP-Polls < 2.76.0 - IP Validation Bypass
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-21 · updated 2026-06-17
Description
The WP-Polls WordPress plugin before 2.76.0 prioritizes getting a visitor's IP from certain HTTP headers over PHP's REMOTE_ADDR, which makes it possible to bypass IP-based limitations to vote in certain situations.
Affected products
- WP-Polls: before 2.76.0 — fixed in 2.76.0
How to fix
Upgrade to a fixed version: WP-Polls 2.76.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c1896ab9-9585-40e2-abbf-ef5153b3c6b2
- https://www.hightechdad.com/2009/12/21/warning-wp-polls-wordpress-poll-plugin-can-be-exploited/
- https://wpscan.com/vulnerability/c1896ab9-9585-40e2-abbf-ef5153b3c6b2
- https://www.hightechdad.com/2009/12/21/warning-wp-polls-wordpress-poll-plugin-can-be-exploited/
Get alerted when CVE-2022-1581 or the next vulnerability affects your stack