What’s Vulnerable › Vulnerabilities
CVE-2022-1600: YOP Poll < 6.4.3 - IP Spoofing
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-01 · updated 2026-06-17
- Weakness: CWE-639
Description
The YOP Poll WordPress plugin before 6.4.3 prioritizes getting a visitor's IP from certain HTTP headers over PHP's REMOTE_ADDR, which makes it possible to bypass IP-based limitations to vote in certain situations.
Affected products
- YOP Poll: before 6.4.3 — fixed in 6.4.3
How to fix
Upgrade to a fixed version: YOP Poll 6.4.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2b7445fd-0992-47cd-9a48-f5f18d8171f7
- https://wpscan.com/vulnerability/2b7445fd-0992-47cd-9a48-f5f18d8171f7
Get alerted when CVE-2022-1600 or the next vulnerability affects your stack