What’s Vulnerable › Vulnerabilities
CVE-2022-1614: WP-Email < 2.69.0 - Anti-Spam Protection Bypass via IP Spoofing
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-20 · updated 2026-06-17
- Weakness: CWE-639
Description
The WP-EMail WordPress plugin before 2.69.0 prioritizes getting a visitor's IP from certain HTTP headers over PHP's REMOTE_ADDR, which makes it possible to bypass IP-based anti-spamming restrictions.
Affected products
- WP-EMail: before 2.69.0 — fixed in 2.69.0
How to fix
Upgrade to a fixed version: WP-EMail 2.69.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a5940d0b-6b88-4418-87e2-02c0897bc2f1
- https://wpscan.com/vulnerability/a5940d0b-6b88-4418-87e2-02c0897bc2f1
Get alerted when CVE-2022-1614 or the next vulnerability affects your stack