What’s Vulnerable › Vulnerabilities
CVE-2022-1615
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-01 · updated 2026-06-17
- Weakness: CWE-330
Description
In Samba, GnuTLS gnutls_rnd() can fail and give predictable random values.
Affected products
- Fedoraproject Fedora: 37
- Samba: from 4.1.0 before 4.17.0 — fixed in 4.17.0
How to fix
Upgrade to a fixed version: Samba 4.17.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.samba.org/show_bug.cgi?id=15103
- https://gitlab.com/samba-team/samba/-/merge_requests/2644
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZTTOLTHUHOV4SHCHCB5TAA4FQVJAWN4P/
- https://security.gentoo.org/glsa/202309-06
- https://bugzilla.samba.org/show_bug.cgi?id=15103
- https://gitlab.com/samba-team/samba/-/merge_requests/2644
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZTTOLTHUHOV4SHCHCB5TAA4FQVJAWN4P/
- https://security.gentoo.org/glsa/202309-06
Get alerted when CVE-2022-1615 or the next vulnerability affects your stack