What’s Vulnerable › Vulnerabilities
CVE-2022-1625: New User Approve < 2.4 - Arbitrary Settings Update & Invitation Code Creation via CSRF
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-27 · updated 2026-06-17
- Weakness: CWE-352
Description
The New User Approve WordPress plugin before 2.4 does not have CSRF check in place when updating its settings and adding invitation codes, which could allow attackers to add invitation codes (for bypassing the provided restrictions) and to change plugin settings by tricking admin users into visiting specially crafted websites.
Affected products
- Saad Iqbal New User Approve: before 2.4 — fixed in 2.4
How to fix
Upgrade to a fixed version: Saad Iqbal New User Approve 2.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e1693318-900c-47f1-bb77-008b0d33327f
- https://wpscan.com/vulnerability/e1693318-900c-47f1-bb77-008b0d33327f
Get alerted when CVE-2022-1625 or the next vulnerability affects your stack