What’s Vulnerable › Vulnerabilities
CVE-2022-1629: Buffer Over-read in function find_next_quote in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-10 · updated 2026-06-17
- Weakness: CWE-126
Description
Buffer Over-read in function find_next_quote in GitHub repository vim/vim prior to 8.2.4925. This vulnerabilities are capable of crashing software, Modify Memory, and possible remote execution
Affected products
- Apple macOS: before 13.0 — fixed in 13.0
- Fedoraproject Fedora: 34, 35
- vim/vim: before 8.2.4925 — fixed in 8.2.4925
How to fix
Upgrade to a fixed version: Apple macOS 13.0; vim/vim 8.2.4925. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- https://github.com/vim/vim/commit/53a70289c2712808e6d4e88927e03cac01b470dd
- https://huntr.dev/bounties/e26d08d4-1886-41f0-9af4-f3e1bf3d52ee
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HIP7KG7TVS5YF3QREAY2GOGUT3YUBZAI/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://support.apple.com/kb/HT213488
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- https://github.com/vim/vim/commit/53a70289c2712808e6d4e88927e03cac01b470dd
- https://huntr.dev/bounties/e26d08d4-1886-41f0-9af4-f3e1bf3d52ee
Get alerted when CVE-2022-1629 or the next vulnerability affects your stack