What’s Vulnerable › Vulnerabilities
CVE-2022-1647: FormCraft Basic < 1.2.6 - Admin+ Stored Cross Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The FormCraft WordPress plugin before 1.2.6 does not sanitise and escape Field Labels, allowing high privilege users such as admin to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- nCrafts FormCraft: before 1.2.6 — fixed in 1.2.6
How to fix
Upgrade to a fixed version: nCrafts FormCraft 1.2.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8e8f6b08-90ab-466a-9828-dca0c0da2c9c
- https://wpscan.com/vulnerability/8e8f6b08-90ab-466a-9828-dca0c0da2c9c
Get alerted when CVE-2022-1647 or the next vulnerability affects your stack