What’s Vulnerable › Vulnerabilities
CVE-2022-1650: Improper Removal of Sensitive Information Before Storage or Transfer in eventsource/eventsource
- Severity: critical (CVSS 9.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-12 · updated 2026-06-17
- Weakness: CWE-212
Description
Improper Removal of Sensitive Information Before Storage or Transfer in GitHub repository eventsource/eventsource prior to v2.0.2.
Affected products
- Debian Linux: 10.0
- Eventsource: before 1.1.1; from 2.0.0 before 2.0.2 — fixed in 1.1.1, 2.0.2
- Npm Eventsource: before 1.1.1; from 2.0.0 before 2.0.2 — fixed in 1.1.1, 2.0.2
How to fix
Upgrade to a fixed version: Eventsource 1.1.1, 2.0.2; Npm Eventsource 1.1.1, 2.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/eventsource/eventsource/commit/10ee0c4881a6ba2fe65ec18ed195ac35889583c4
- https://huntr.dev/bounties/dc9e467f-be5d-4945-867d-1044d27e9b8e
- https://lists.debian.org/debian-lts-announce/2022/12/msg00021.html
- https://github.com/eventsource/eventsource/commit/10ee0c4881a6ba2fe65ec18ed195ac35889583c4
- https://huntr.dev/bounties/dc9e467f-be5d-4945-867d-1044d27e9b8e
- https://lists.debian.org/debian-lts-announce/2022/12/msg00021.html
Get alerted when CVE-2022-1650 or the next vulnerability affects your stack