What’s Vulnerable › Vulnerabilities
CVE-2022-1652
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-02 · updated 2026-06-17
- Weakness: CWE-416
Description
Linux Kernel could allow a local attacker to execute arbitrary code on the system, caused by a concurrency use-after-free flaw in the bad_flp_intr function. By executing a specially-crafted program, an attacker could exploit this vulnerability to execute arbitrary code or cause a denial of service condition on the system.
Affected products
- Debian Linux: 10.0
- Linux kernel: from 2.6.12 before 4.9.316; from 4.10 before 4.14.281; from 4.15 before 4.19.245; from 4.20 before 5.4.196; from 5.5 before 5.10.118; from 5.11 before 5.15.42 — fixed in 4.14.281, 4.19.245, 4.9.316, 5.10.118, 5.15.42, 5.17.10
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700S Firmware: all versions
- Red Hat Enterprise Linux: 9.0
How to fix
Upgrade to a fixed version: Linux kernel 4.14.281, 4.19.245, 4.9.316, 5.10.118. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1832397
- https://francozappa.github.io/about-bias/
- https://kb.cert.org/vuls/id/647177/
- https://security.netapp.com/advisory/ntap-20220722-0002/
- https://www.debian.org/security/2022/dsa-5173
- https://bugzilla.redhat.com/show_bug.cgi?id=1832397
- https://francozappa.github.io/about-bias/
- https://kb.cert.org/vuls/id/647177/
- https://security.netapp.com/advisory/ntap-20220722-0002/
- https://www.debian.org/security/2022/dsa-5173
Get alerted when CVE-2022-1652 or the next vulnerability affects your stack