What’s Vulnerable › Vulnerabilities

CVE-2022-1664: directory traversal for in-place extracts with untrusted v2 and v3 source packages with debian.tar

Description

Dpkg::Source::Archive in dpkg, the Debian package management system, before version 1.21.8, 1.20.10, 1.19.8, 1.18.26 is prone to a directory traversal vulnerability. When extracting untrusted source packages in v2 and v3 source package formats that include a debian.tar, the in-place extraction can lead to directory traversal situations on specially crafted orig.tar and debian.tar tarballs.

Affected products

How to fix

Upgrade to a fixed version: Debian dpkg 1.18.26, 1.19.8, 1.20.10, 1.21.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-1664 or the next vulnerability affects your stack