What’s Vulnerable › Vulnerabilities
CVE-2022-1670
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-19 · updated 2026-06-17
Description
When generating a user invitation code in Octopus Server, the validity of this code can be set for a specific number of users. It was possible to bypass this restriction of validity to create extra user accounts above the initial number of invited users.
Affected products
- Octopus Deploy Octopus Server: from 0.9 before 2021.3.12533; from 2022.1.0 before 2022.1.53 — fixed in 2021.3.12533, 2022.1.53
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2021.3.12533, 2022.1.53. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2022/sa2022-04/
- https://advisories.octopus.com/post/2022/sa2022-04/
Get alerted when CVE-2022-1670 or the next vulnerability affects your stack