What’s Vulnerable › Vulnerabilities
CVE-2022-1672: Insights from Google PageSpeed < 4.0.7 - Multiple CSRF
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-17 · updated 2026-06-17
- Weakness: CWE-352
Description
The Insights from Google PageSpeed WordPress plugin before 4.0.7 does not verify for CSRF before doing various actions such as deleting Custom URLs, which could allow attackers to make a logged in admin perform such actions via CSRF attacks
Affected products
- Insights from Google PageSpeed: before 4.0.7 — fixed in 4.0.7
How to fix
Upgrade to a fixed version: Insights from Google PageSpeed 4.0.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5c5955d7-24f0-45e6-9c27-78ef50446dad
- https://wpscan.com/vulnerability/5c5955d7-24f0-45e6-9c27-78ef50446dad
Get alerted when CVE-2022-1672 or the next vulnerability affects your stack