What’s Vulnerable › Vulnerabilities
CVE-2022-1673: WooCommerce Green Wallet Gateway < 1.0.2 - Reflected Cross Site Scripting in checkout page
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The WooCommerce Green Wallet Gateway WordPress plugin before 1.0.2 does not escape the error_envision query parameter before outputting it to the page, leading to a Reflected Cross-Site Scripting vulnerability.
Affected products
- WooCommerce Green Wallet Gateway: before 1.0.2 — fixed in 1.0.2
How to fix
Upgrade to a fixed version: WooCommerce Green Wallet Gateway 1.0.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/14283389-a6b8-4dd8-9441-f16fcc4ab3c0
- https://wpscan.com/vulnerability/14283389-a6b8-4dd8-9441-f16fcc4ab3c0
Get alerted when CVE-2022-1673 or the next vulnerability affects your stack