What’s Vulnerable › Vulnerabilities
CVE-2022-1691: Realty Workstation < 1.0.15 - Agent SQLi
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-08 · updated 2026-06-17
- Weakness: CWE-89
Description
The Realty Workstation WordPress plugin before 1.0.15 does not sanitise and escape the trans_edit parameter before using it in a SQL statement when an agent edit a transaction, leading to an SQL injection
Affected products
- realtyworkstation Realty Workstation: before 1.0.15 — fixed in 1.0.15
How to fix
Upgrade to a fixed version: realtyworkstation Realty Workstation 1.0.15. Check the vendor advisory for mitigations.
References
- https://bulletin.iese.de/post/realty-workstation_1-0-6
- https://wpscan.com/vulnerability/f9363b4c-c434-4f15-93f8-46162d2d7049
- https://bulletin.iese.de/post/realty-workstation_1-0-6
- https://wpscan.com/vulnerability/f9363b4c-c434-4f15-93f8-46162d2d7049
Get alerted when CVE-2022-1691 or the next vulnerability affects your stack