What’s Vulnerable › Vulnerabilities
CVE-2022-1707: Google Tag Manager for WordPress <= 1.15 - Reflected Cross-Site Scripting via Site Search
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 89.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Google Tag Manager for WordPress plugin for WordPress is vulnerable to reflected Cross-Site Scripting via the s parameter due to the site search populating into the data layer of sites with insufficient sanitization in versions up to an including 1.15. The affected file is ~/public/frontend.php and this could be exploited by unauthenticated attackers.
Affected products
- duracelltomi GTM4WP – A Google Tag Manager (GTM) plugin for WordPress: before 1.15.1 — fixed in 1.15.1
How to fix
Upgrade to a fixed version: duracelltomi GTM4WP – A Google Tag Manager (GTM) plugin for WordPress 1.15.1. Check the vendor advisory for mitigations.
References
- https://github.com/duracelltomi/gtm4wp/blob/1.15/public/frontend.php#L298
- https://github.com/duracelltomi/gtm4wp/blob/1.15/public/frontend.php#L782
- https://github.com/duracelltomi/gtm4wp/issues/224
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0435ae14-c1fd-4611-acbe-5f3bafd4bb6a?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1707
- https://github.com/duracelltomi/gtm4wp/blob/1.15/public/frontend.php#L298
- https://github.com/duracelltomi/gtm4wp/blob/1.15/public/frontend.php#L782
- https://github.com/duracelltomi/gtm4wp/issues/224
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0435ae14-c1fd-4611-acbe-5f3bafd4bb6a?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1707
Get alerted when CVE-2022-1707 or the next vulnerability affects your stack