What’s Vulnerable › Vulnerabilities
CVE-2022-1727: Improper Input Validation in jgraph/drawio
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-18 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation in GitHub repository jgraph/drawio prior to 18.0.6.
Affected products
- jgraph/drawio: before 18.0.6 — fixed in 18.0.6
How to fix
Upgrade to a fixed version: jgraph/drawio 18.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/jgraph/drawio/commit/4deecee18191f67e242422abf3ca304e19e49687
- https://huntr.dev/bounties/b242e806-fc8c-41c0-aad7-e0c9c37ecdee
- https://github.com/jgraph/drawio/commit/4deecee18191f67e242422abf3ca304e19e49687
- https://huntr.dev/bounties/b242e806-fc8c-41c0-aad7-e0c9c37ecdee
Get alerted when CVE-2022-1727 or the next vulnerability affects your stack