What’s Vulnerable › Vulnerabilities
CVE-2022-1728: Allowing long password leads to denial of service in polonel/trudesk in polonel/trudesk
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-16 · updated 2026-06-17
- Weakness: CWE-190
Description
Allowing long password leads to denial of service in polonel/trudesk in GitHub repository polonel/trudesk prior to 1.2.2. This vulnerability can be abused by doing a DDoS attack for which genuine users will not able to access resources/applications.
Affected products
- polonel/trudesk: before 1.2.2 — fixed in 1.2.2
How to fix
Upgrade to a fixed version: polonel/trudesk 1.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/polonel/trudesk/commit/e836d04d16787c2c9c72e7bf011cf396d1f73c19
- https://huntr.dev/bounties/3c6cb129-6995-4722-81b5-af052572b519
- https://github.com/polonel/trudesk/commit/e836d04d16787c2c9c72e7bf011cf396d1f73c19
- https://huntr.dev/bounties/3c6cb129-6995-4722-81b5-af052572b519
Get alerted when CVE-2022-1728 or the next vulnerability affects your stack