What’s Vulnerable › Vulnerabilities
CVE-2022-1730: Cross-site Scripting (XSS) - Stored in jgraph/drawio
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository jgraph/drawio prior to 18.0.4.
Affected products
- jgraph/drawio: before 18.0.4 — fixed in 18.0.4
How to fix
Upgrade to a fixed version: jgraph/drawio 18.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/jgraph/drawio/commit/4deecee18191f67e242422abf3ca304e19e49687
- https://huntr.dev/bounties/fded4835-bd49-4533-8311-1d71e0ed7c00
- https://github.com/jgraph/drawio/commit/4deecee18191f67e242422abf3ca304e19e49687
- https://huntr.dev/bounties/fded4835-bd49-4533-8311-1d71e0ed7c00
Get alerted when CVE-2022-1730 or the next vulnerability affects your stack