What’s Vulnerable › Vulnerabilities
CVE-2022-1735: Classic Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-17 · updated 2026-06-17
- Weakness: CWE-120
Description
Classic Buffer Overflow in GitHub repository vim/vim prior to 8.2.4969.
Affected products
- Apple macOS: before 13.0 — fixed in 13.0
- vim/vim: before 8.2.4969 — fixed in 8.2.4969
How to fix
Upgrade to a fixed version: Apple macOS 13.0; vim/vim 8.2.4969. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- https://github.com/vim/vim/commit/7ce5b2b590256ce53d6af28c1d203fb3bc1d2d97
- https://huntr.dev/bounties/c9f85608-ff11-48e4-933d-53d1759d44d9
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://support.apple.com/kb/HT213488
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- https://github.com/vim/vim/commit/7ce5b2b590256ce53d6af28c1d203fb3bc1d2d97
- https://huntr.dev/bounties/c9f85608-ff11-48e4-933d-53d1759d44d9
- https://security.gentoo.org/glsa/202208-32
Get alerted when CVE-2022-1735 or the next vulnerability affects your stack